94 z28 shutting off randomly when driving? Help?! - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 4th Gen (1993-97) Camaro and Firebird Tech

Join Camaro Zone Today
Reply
 
LinkBack Thread Tools
 
Old 07-02-2013, 03:30 PM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: Jul 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
94 z28 shutting off randomly when driving? Help?!

Afternoon everyone.

It seems I have a slight problem with me Z... I'll be driving and randomly, as I'm accelerating, the engine will die. I'll still have full electricity in the car (radio playing dash lights on, headlights, etc. I'm just stumped as to what to look at to fix it.

I've replaced the fuel pump, fuel filter, ICM, the battery is barely a year old, new starter, cat, muffler, oil pressure sensor, and has a tranny rebuild less than 3000 miles, and many other random things.

The only thing I can think of that may be coincidental, is that it happens sometimes when the car is warm, but not always, and it's shut down twice right after getting gas. The last time I was stuck in the middle of the parking lot in the rain... -no fun, if you can imagine.

Any help is greatly appreciated, I just don't want to continue dumping money guessing at the problem. And Id like to run codes, but no one around me has an obd-1 scanner. Just my luck.
__________________

__________________
Koreywantsagto is offline   Reply With Quote
Old 07-02-2013, 03:45 PM   #2
The expert of nothing.
Feedback Score: 1 reviews
 
AjJeep09's Avatar
 
Join Date: Dec 2011
Location: illinois
Posts: 4,317
Thanks: 30
Thanked 33 Times in 29 Posts
Garage
You should check the fuel pressure on it, I know you mentioned the fuel pump was recently replaced but the regulator could be bad. I would first check the fuel pressure though and see where you're at with that.
__________________

__________________
(⌐■_■)
AjJeep09 is offline   Reply With Quote
Old 07-02-2013, 04:13 PM   #3
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,265
Thanks: 35
Thanked 939 Times in 849 Posts
Garage
Possible bad electrical ignition switch or a bad connection to it.
Other thing could be the optispark, they've been known to behave like that.
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 191k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..
NavyVet is online now   Reply With Quote
Old 07-02-2013, 05:04 PM   #4
New Member
Feedback Score: 0 reviews
 
Join Date: Apr 2013
Location: Rochester, Indiana
Posts: 13
Thanks: 0
Thanked 4 Times in 3 Posts
Try shimming your icm out a bit. It could be heat soak causing it when the icm gets to hot.
__________________
94 Z28, M6-RPM Stage 3,Spec 3,Forged 383,4-bolt,12.8,LE2,Eagle 6"H beam,306 for now,42lb injectors,58 BBK,Meziere EWP, Pacesetter,BMR SFC,LCA,Panhard,k-member,spohnTA and loop
bowtiedad_z28 is offline   Reply With Quote
Old 07-02-2013, 07:08 PM   #5
Veteran Member
Feedback Score: 2 reviews
 
GhoSSt's Avatar
 
Join Date: Jan 2012
Location: Kenosha, WI
Posts: 1,826
Thanks: 46
Thanked 51 Times in 40 Posts
Garage
My 97 Z28 did the same thing.. had a damn vacuum leak. Don't remember which little hose was being a pain in the ***, but I just changed anyone that was dry rotted, and it stopped.
__________________

2010 Camaro SS, 2SS, RS pkg, 6-Speed. (When privileged to drive)
2002 S10 LS Crew Cab 4x4 ZR5 (Up for sale soon)
2004 Cavalier LS Standard (DD)
March 2012 COTM (01' SS)
Ooorah! Semper Fidelis
GhoSSt is offline   Reply With Quote
Old 07-03-2013, 12:39 PM   #6
Senior Member
Feedback Score: 0 reviews
 
sandbag747's Avatar
 
Join Date: Sep 2011
Posts: 684
Thanks: 25
Thanked 11 Times in 10 Posts
I know you replaced the fuel filter and the fuel pump but it sounds like something is clogged up in the fuel. Does it die out at high RPM's or high speeds?
__________________
sandbag747 is offline   Reply With Quote
Old 07-03-2013, 10:00 PM   #7
Member
Feedback Score: 0 reviews
 
Join Date: Apr 2013
Posts: 112
Thanks: 0
Thanked 9 Times in 8 Posts
I would also remove your coil pack and inspect it for cracks in the epoxy. I had the same problem only mine completely quit. I didn't find it until after I changed out the opti spark distributor and still had a non running car.
__________________
tegeye1000 is offline   Reply With Quote
Old 07-10-2013, 04:32 PM   #8
Member
Feedback Score: 0 reviews
 
mcgilljb92's Avatar
 
Join Date: May 2012
Posts: 102
Thanks: 0
Thanked 0 Times in 0 Posts
If u have a bad ground it will shutoff randomly happend to mine and wen i went to crank it id hear engine reving sound coming out of my speakers
__________________
mcgilljb92 is offline   Reply With Quote
Old 07-11-2013, 10:56 PM   #9
Junior Member
Feedback Score: 0 reviews
 
Eazee's Avatar
 
Join Date: May 2013
Posts: 37
Thanks: 0
Thanked 1 Time in 1 Post
Read the codes it's throwing I had the same exact problem it was a bad Opti Spark
__________________
Eazee is offline   Reply With Quote
Old 07-11-2013, 11:27 PM   #10
CZ's Audio Yoda
Feedback Score: 1 reviews
 
Ercmann's Avatar
 
Join Date: Nov 2011
Location: River Valley in The Natural State
Posts: 8,556
Thanks: 35
Thanked 378 Times in 350 Posts
Garage
Quote:
Originally Posted by mcgilljb92 View Post
If u have a bad ground it will shutoff randomly happend to mine and wen i went to crank it id hear engine reving sound coming out of my speakers
Engine revving sounds coming through the speakers is called "ground loop". Which I've already covered in a previous post. To correct this, make sure the grounds are secure and if you have more than 1 external amp, make sure the amp's are grounded at the same point. Usually the best place the ground the HU is the using the factory ground wire. Either factory HU or after market. Reason, if you think about it, "have you ever heard ground loop from a factory system?" I answer this with a resounding No. If you have, it was probably an old car with wiring issues, an old HU or someone "tried" to modify the wiring in some way.
__________________

__________________

2001 Camaro SS LS1
T56
"Concert Hall On Wheels"
"It's better to have it and not need it, than to need it and not have it"
http://www.camarozone.com/forum/f18/erics-01-ss-
mod-thread-178452/
http://www.camarozone.com/forum/f27/...m-poll-180546/

Last edited by Ercmann; 07-12-2013 at 12:08 AM.
Ercmann is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is my camaro shutting off on me? Harrington19 4th Gen (1993-97) Camaro and Firebird Tech 13 05-28-2013 06:45 PM
96 camaro shutting off problems? 96camaro 4th Gen (1993-97) Camaro and Firebird Tech 10 11-30-2012 02:15 AM
apparently, the US is shutting down Battousai General Discussion 36 04-08-2011 09:07 PM
93 z28 runs great but randomly dies and wont restart 93Z 4th Gen (1993-97) Camaro and Firebird Tech 12 07-26-2010 12:47 PM
Stock radio randomly shutting off while driving Y2K Sally General Camaro & Firebird Tech 9 05-07-2010 04:59 PM




Powered by vBadvanced CMPS v3.2.3

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 10:11 AM.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

Camaro News Delivered to your Email!

Get the latest Camaro news straight to your inbox!

unsusbcribe at anytime with one click

Close [X]