running hot - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 4th Gen (1993-97) Camaro and Firebird Tech

Join Camaro Zone Today
Reply
 
LinkBack Thread Tools
 
Old 07-26-2013, 11:42 PM   #1
Member
Feedback Score: 0 reviews
 
grgguy's Avatar
 
Join Date: Feb 2013
Location: SoCal
Posts: 156
Thanks: 6
Thanked 3 Times in 3 Posts
Garage
running hot

So I've been searching the threads and can't find the answer. Here's the deal. 94 Z28 w/ 96k on it. When driving on the freeway or above 45 my temp gauge rides right at 180 or a hair above. But when I get into traffic it start to rise. It will go up slowly until I get it up to speed again ( all the way to the 3rd hash mark ). Thing is I don't want it to overheat. So here's what I've done so far .
1 coolant flush
2 new thermostat
3 new temp sensor on water pump
4 looked for debris between the radiator and a/c condensor (none)
5 New radiator cap

None of these things have helped , I've checked the fans and yes they are coming on. I took it to the local gmc dealer and they are saying i need a new radiator? Saying there's a blockage restricting the flow. Wouldn't the coolant flush have cleared that out ? They want 500.00 for it installed

What else could it be ? Or do I actually need a radiator
__________________

__________________
98 Firebird 3.8 V6 ( gave to my son )
94 Z28 LT1 current
grgguy is offline   Reply With Quote
Old 07-27-2013, 12:17 AM   #2
New Member
Feedback Score: 0 reviews
 
96 z28's Avatar
 
Join Date: Apr 2013
Posts: 16
Thanks: 5
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by grgguy View Post
So I've been searching the threads and can't find the answer. Here's the deal. 94 Z28 w/ 96k on it. When driving on the freeway or above 45 my temp gauge rides right at 180 or a hair above. But when I get into traffic it start to rise. It will go up slowly until I get it up to speed again ( all the way to the 3rd hash mark ). Thing is I don't want it to overheat. So here's what I've done so far .
1 coolant flush
2 new thermostat
3 new temp sensor on water pump
4 looked for debris between the radiator and a/c condensor (none)
5 New radiator cap

None of these things have helped , I've checked the fans and yes they are coming on. I took it to the local gmc dealer and they are saying i need a new radiator? Saying there's a blockage restricting the flow. Wouldn't the coolant flush have cleared that out ? They want 500.00 for it installed

What else could it be ? Or do I actually need a radiator
Dude they run hot for a good while and then cool way down. Just keep an eye on it and let it ride out. If it does hit the red. Then there's something wrong. But it sounds usual to me
__________________

__________________
96 z28 is offline   Reply With Quote
Old 07-27-2013, 12:57 AM   #3
Veteran Member
Feedback Score: 0 reviews
 
y87bird00's Avatar
 
Join Date: Apr 2012
Posts: 1,930
Thanks: 38
Thanked 36 Times in 30 Posts
Garage
Just buy a radiator from rockauto.com and put it in yourself. Very easy job to do.
__________________
2000 firebird v6 y87
Lm7 5.3 swap in progress
y87bird00 is offline   Reply With Quote
Old 07-27-2013, 09:37 AM   #4
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 14,332
Thanks: 32
Thanked 824 Times in 753 Posts
Garage
Quote:
Originally Posted by grgguy View Post
So I've been searching the threads and can't find the answer. Here's the deal. 94 Z28 w/ 96k on it. When driving on the freeway or above 45 my temp gauge rides right at 180 or a hair above. But when I get into traffic it start to rise. It will go up slowly until I get it up to speed again ( all the way to the 3rd hash mark ). Thing is I don't want it to overheat. So here's what I've done so far .
1 coolant flush
2 new thermostat
3 new temp sensor on water pump
4 looked for debris between the radiator and a/c condensor (none)
5 New radiator cap

None of these things have helped , I've checked the fans and yes they are coming on. I took it to the local gmc dealer and they are saying i need a new radiator? Saying there's a blockage restricting the flow. Wouldn't the coolant flush have cleared that out ? They want 500.00 for it installed

What else could it be ? Or do I actually need a radiator
Sounds perfectly normal to me if you don't have the A/C on.
If the A/C is not on the low speed fans don't kick in until temp reaches 225
The high speed fans will kick in at 235
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 188k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..
lift I .500 E .510 duration I 266 E 276
NavyVet is offline   Reply With Quote
The Following User Says Thank You to NavyVet For This Useful Post:
Old 07-28-2013, 12:35 AM   #5
New Member
Feedback Score: 0 reviews
 
96 z28's Avatar
 
Join Date: Apr 2013
Posts: 16
Thanks: 5
Thanked 0 Times in 0 Posts
I wouldn't buy anything more until you're sure something's wrong. I honestly don't think anything is wrong
__________________
96 z28 is offline   Reply With Quote
Old 07-28-2013, 12:00 PM   #6
New Member
Feedback Score: 0 reviews
 
Kil R Wail's Avatar
 
Join Date: Jul 2013
Location: Baltimore/Washington DC
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
My 95 Z runs just like that. It's not unusual. Unless the gauge is actually going into the red, don't worry about it. My 94 Caprice Wagon with LT1 runs the same way as well. If it ain't broke...
__________________
Kil R Wail is offline   Reply With Quote
Old 07-28-2013, 12:35 PM   #7
Member
Feedback Score: 0 reviews
 
grgguy's Avatar
 
Join Date: Feb 2013
Location: SoCal
Posts: 156
Thanks: 6
Thanked 3 Times in 3 Posts
Garage
I'm going to take the advice and just keep an eye on the temp. Yesterday while driving it it never got to the 1/2 way mark and i didn't have the a/c on either( best its behaved since I bought it ). I'm thinking I had an air pocket in there and the mechanic at GMC got it out. But the salesman being a salesman wants to sell me something..

Thanks Guys !
__________________
98 Firebird 3.8 V6 ( gave to my son )
94 Z28 LT1 current

Last edited by grgguy; 07-28-2013 at 12:36 PM.
grgguy is offline   Reply With Quote
Old 07-28-2013, 12:58 PM   #8
Veteran Member
Feedback Score: 0 reviews
 
95formyLt1's Avatar
 
Join Date: Apr 2011
Location: Connecticut
Posts: 1,280
Thanks: 35
Thanked 20 Times in 17 Posts
If im sitting in traffic and the temp needle starts to rise i just give it a quick few revs to get the waterpump going faster and it instantly cools down. If you are still worried put some WaterWetter in the coolant and it helps a bit.
__________________


Towing is one fun job
95formyLt1 is offline   Reply With Quote
Old 07-28-2013, 01:44 PM   #9
Member
Feedback Score: 0 reviews
 
grgguy's Avatar
 
Join Date: Feb 2013
Location: SoCal
Posts: 156
Thanks: 6
Thanked 3 Times in 3 Posts
Garage
Water wetter ?
__________________
98 Firebird 3.8 V6 ( gave to my son )
94 Z28 LT1 current
grgguy is offline   Reply With Quote
Old 07-28-2013, 03:23 PM   #10
CZ's Audio Yoda
Feedback Score: 1 reviews
 
Ercmann's Avatar
 
Join Date: Nov 2011
Location: River Valley
Posts: 7,439
Thanks: 32
Thanked 290 Times in 273 Posts
Garage
Quote:
Originally Posted by grgguy View Post
Water wetter ?
It's an engine coolant additive.
Attached Thumbnails
Click image for larger version

Name:	image-2427231828.jpg
Views:	28
Size:	44.3 KB
ID:	21382  
__________________

__________________

2001 Camaro SS LS1
6 Speed Manual
"Concert Hall On Wheels"
"It's better to have it and not need it, than to need it and not have it"
http://www.camarozone.com/forum/f18/...thread-178452/
Ercmann is offline   Reply With Quote
The Following User Says Thank You to Ercmann For This Useful Post:
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
My 87 firebird is running hot. brentthemechanic 3rd Gen (1982-92) Camaro and Firebird Tech 8 11-26-2012 05:35 PM
88 bird running hot daveconner1984 3rd Gen (1982-92) Camaro and Firebird Tech 19 10-22-2011 12:57 AM
Car running a little hot and idles high when hot in park Firebird_formula 4th Gen (1993-97) Camaro and Firebird Tech 6 06-30-2009 02:18 AM
running hot 69bird 3rd Gen (1982-92) Camaro and Firebird Tech 3 12-26-2008 05:00 PM
is my car running hot?? sotexkilla08 V6 Camaro and Firebird Tech 4 08-26-2008 05:51 PM




Powered by vBadvanced CMPS v3.2.3

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 06:12 AM.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

Camaro News Delivered to your Email!

Get the latest Camaro news straight to your inbox!

unsusbcribe at anytime with one click

Close [X]