TPS replacement - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 4th Gen (1993-97) Camaro and Firebird Tech

Reply
 
LinkBack Thread Tools
 
Old 05-06-2017, 07:17 PM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: Apr 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
TPS replacement

95 Camaro 3.4l I replaced my tps and when I start the car the rpms just keep rising. It starts at 1000 rpms and with in 5 secs it's up to 2500 and climbing. I made sure it was aligned just as the old one. I thought it was kind of weird that you had to place it and then turn it slightly clock wise to line up the holes. Is that normal?

Sent from my SM-G935T using Camaro Zone mobile app
__________________
95 camaro 3.4l
Mottomotto is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-07-2017, 01:55 PM   #2
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 18,197
Thanks: 49
Thanked 1,212 Times in 1,087 Posts
Garage
Having to insert the TPS and then rotate it slightly to line it up is normal..
Rising RPM is not.
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 207k miles and counting.
Total engine rebuild at 187,020 miles. AIR delete, bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs.
Custom leather interior at 190k miles. Total repaint 193k Miles
NavyVet is offline   Reply With Quote
Old 05-07-2017, 11:35 PM   #3
Junior Member
Feedback Score: 0 reviews
 
GaryDoug's Avatar
 
Join Date: Dec 2012
Location: Florida
Posts: 68
Thanks: 0
Thanked 12 Times in 11 Posts
It sounds like the TPS or it's connector is defective. Are you seeing any trouble codes or a lit SES lamp? The idle RPM would normally climb if the TPS reading is higher than a normal idle position, since the pcm is setting it high to avoid stalling when the throttle closes.

Another possibility is that the TPS is reading a voltage higher than normal idle value. Can you measure the voltage with the throttle closed? It should be 0.3 to 1.3 volts DC
__________________
1998 Trans Am - LS1 - 4spd Auto - strictly stock

Last edited by GaryDoug; 05-07-2017 at 11:43 PM. Reason: added info
GaryDoug is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-08-2017, 01:21 AM   #4
New Member
Feedback Score: 0 reviews
 
Join Date: Apr 2017
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Ok ty both I wasn't sure about the rotating and I will check the voltage.

Sent from my SM-G935T using Camaro Zone mobile app
__________________
95 camaro 3.4l
Mottomotto is offline   Reply With Quote
Old 05-15-2017, 11:01 PM   #5
New Member
Feedback Score: 0 reviews
 
Join Date: Apr 2017
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
It happened to me a few days ago while I was cleaning the TB and had to remove the TPS.

In my case the care started fine and then the RPM started rising like to 1500 2000 in idle. (???)

Curious thing was that if I turned off the car and started it again all was fine.

I did that a couple of times and took it for a ride. Turning on the A/C also helped reducing the idle RPM.

I took it for a ride and after a while all was back to normal.

Not sure it was that or the fact that I also unplugged both battery terminals for a while.

You may give it a try. Good Luck !!
Mark Miller is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tps short Ryan32 4th Gen (1993-97) Camaro and Firebird Tech 7 03-29-2015 07:41 PM
Tps how to? Ozark Iroc 3rd Gen (1982-92) Camaro and Firebird Tech 2 10-18-2013 06:51 PM
replacing tps TeXasBiRD91 V6 Camaro and Firebird Tech 3 09-01-2011 06:41 PM
V6 tps LS1GOAT V6 Camaro and Firebird Tech 16 04-02-2011 10:09 PM
faulty tps? fear_37 4th Gen (1993-97) Camaro and Firebird Tech 5 08-02-2009 02:00 PM


Powered by vBadvanced CMPS v3.2.3


All times are GMT -4. The time now is 07:31 AM.
Powered by vBulletin®
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.