Need Help Fellas.. - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > V6 Camaro and Firebird Tech

Join Camaro Zone Today
Reply
 
LinkBack Thread Tools
 
Old 09-09-2013, 07:32 PM   #1
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Need Help Fellas..

Picked up my car today from mech shop and problems continue
Haven't posted in awhile but I've got some serious issues with my firebird..

Save us a long story:
These occurred rather suddenly..
Symptoms..
Bogging Down
Stalling Out
Loss of Power while driving
Won't rev beyond 4,000RPMS when under hard throttle, and when released from such, car does not idle, dies.
Driving various distances and stalls/dies
50/50 start ups
Start up and dies after short time or seconds

Have replaced EGR valve and Fuel filter in recent days relying on codes and advice. Prior to replacing fuel filter, accelerator had to be depressed to aid start up. Today started up at shop without accelerator aid, but problems persisting.
3.8l 123k miles
__________________

__________________
WVBird99 is offline   Reply With Quote
Old 09-09-2013, 07:34 PM   #2
Always Watching...
Feedback Score: 20 reviews
 
Superman's Avatar
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 21,339
Thanks: 280
Thanked 540 Times in 444 Posts
Send a message via AIM to Superman
Throwing any codes? SES light on?
Check the MAF.
Coil packs/ICM.
Pre-Cat O2 Sensors.
__________________

__________________

Quote:
Originally Posted by 96FBird View Post
... and for that Superman wins the internets
Superman is offline   Reply With Quote
Old 09-09-2013, 07:44 PM   #3
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Only codes that have come up we're EGR Valve stuck open and the p0420 code.. But having made the two repairs mentioned the codes have disappeared yet problems persist. MAFS is new 6k miles old
__________________
WVBird99 is offline   Reply With Quote
Old 09-09-2013, 07:45 PM   #4
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Coil packs, plugs and wires all new
__________________
WVBird99 is offline   Reply With Quote
Old 09-09-2013, 08:02 PM   #5
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Navy vet where art thou lol help!!
__________________
WVBird99 is offline   Reply With Quote
Old 09-09-2013, 09:11 PM   #6
Addicted Member
Feedback Score: 0 reviews
 
HotRodd's Avatar
 
Join Date: Jan 2012
Location: Fenton, MI
Posts: 6,799
Thanks: 118
Thanked 166 Times in 148 Posts
Garage
I would take it back to the mechanic that didn't finish his job to be honest.
__________________
2002 Camaro Z28 Convertible - LS1 5.7L V8
HotRodd is offline   Reply With Quote
Old 09-09-2013, 09:19 PM   #7
Always Watching...
Feedback Score: 20 reviews
 
Superman's Avatar
 
Join Date: Oct 2008
Location: San Antonio, TX
Posts: 21,339
Thanks: 280
Thanked 540 Times in 444 Posts
Send a message via AIM to Superman
Quote:
Originally Posted by HotRodd View Post
I would take it back to the mechanic that didn't finish his job to be honest.
Agreed.
__________________

Quote:
Originally Posted by 96FBird View Post
... and for that Superman wins the internets
Superman is offline   Reply With Quote
Old 09-09-2013, 09:46 PM   #8
CZ's Turbo Gawd
Feedback Score: 1 reviews
 
94 T/A's Avatar
 
Join Date: Sep 2009
Location: Joelton TN
Posts: 6,931
Thanks: 85
Thanked 414 Times in 343 Posts
Garage
Have the fuel pressure checked, sounds like a dying fuel pump.
__________________

-1994 Trans Am Gt: caged, CC503, Garrett GT45, 6Lbs, 3.73
-2011 Camaro SS convertible: SOLD
94 T/A is offline   Reply With Quote
Old 09-09-2013, 09:56 PM   #9
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
It didn't make it a half a block turned it right around and it's back in his shop
__________________
WVBird99 is offline   Reply With Quote
Old 09-10-2013, 09:20 AM   #10
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,414
Thanks: 35
Thanked 953 Times in 861 Posts
Garage
If not the fuel pump, it could be a MAF, ICM or TPS issue.

But it's really time to hook it up to a tech two tool and see what is going on with it.
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 191k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..

Last edited by NavyVet; 09-10-2013 at 09:22 AM.
NavyVet is offline   Reply With Quote
Old 10-14-2013, 07:31 PM   #11
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Well here's the update:
The car has been out of two shops, and both have come to the cumulative conclusion that this is not mechanical nor sensor related. I'm being told this is electrical and in the Harness somewhere, but neither place could pinpoint it. Whatever it is it's causing loss of power
__________________
WVBird99 is offline   Reply With Quote
Old 10-14-2013, 07:49 PM   #12
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jun 2013
Location: Jacksonville, Fl
Posts: 553
Thanks: 10
Thanked 8 Times in 8 Posts
Quote:
Originally Posted by WVBird99 View Post
Well here's the update:
The car has been out of two shops, and both have come to the cumulative conclusion that this is not mechanical nor sensor related. I'm being told this is electrical and in the Harness somewhere, but neither place could pinpoint it. Whatever it is it's causing loss of power
I'm with navy. I don't think electrical could do that much.
__________________
Leo72793 is offline   Reply With Quote
Old 10-14-2013, 09:05 PM   #13
Veteran Member
Feedback Score: 0 reviews
 
the recluse's Avatar
 
Join Date: Oct 2013
Location: Jacksonville, FL
Posts: 1,540
Thanks: 6
Thanked 215 Times in 173 Posts
Garage
Let's start from the beginning... what was the car in the shop for in the first place? The symptoms listed, or did those symptoms show up after the fact?

Second, P0420 code is usually a bad/clogged CAT..if the cat is clogged ALL the symptoms listed will show up...

I don't know what the exhaust setups are on these later half 4th gens, but I would unbolt the Y pipe in front of the cat and run the car straight pipe...it will be loud, yes, but if the symptoms go away, well, free diagnostics, lol

Edit: after looking into it, these do not unbolt, they are weld in. In that case, go to the back of the car, while running, and put your hand over the tailpipe...just put it right over it (don't get burned mind you, do this on a cold start)...if you don't feel much pressure coming out of the tailpipe (normally idling car will blow grass around, clogged cat won't blow dirt around), then I'd look at the CAT...
__________________

Last edited by the recluse; 10-14-2013 at 09:19 PM.
the recluse is offline   Reply With Quote
The Following User Says Thank You to the recluse For This Useful Post:
Old 10-25-2013, 08:02 AM   #14
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Could the Catalytic Converter cause this to happen when heated up?
__________________
WVBird99 is offline   Reply With Quote
Old 10-25-2013, 08:12 AM   #15
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Problem started one morning with not firing up without accelerator help and when it did it spewed out darker smoke and felt/sounded like it was missing.
SES code was EGR valve stuck open.. --> so new EGR valve installed and I cleaned the MAF and throttle body.
However problem as described still occurs.
No codes are being set during this*
From sitting a day or two cold start it may start and run for awhile until warm or at engine temp (205*-212*) and loses power, engine dies without a sound, almost like being suffocated, no jerking or vibration when this happens it just quits.
After it warms up the problem is more consistent, either starts or doesn't and when/if does start it requires accelerator help and black smoke/missing vibration occurs/ high rev during this as well.
__________________
WVBird99 is offline   Reply With Quote
Old 10-25-2013, 08:14 AM   #16
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Last mechanic I had look at it commented it was running Rich when he started it up.
__________________
WVBird99 is offline   Reply With Quote
Old 10-25-2013, 08:24 AM   #17
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,414
Thanks: 35
Thanked 953 Times in 861 Posts
Garage
Try replacing the PCM engine temp sensor.
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 191k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..
NavyVet is offline   Reply With Quote
Old 10-30-2013, 08:52 AM   #18
Member
Feedback Score: 0 reviews
 
WVBird99's Avatar
 
Join Date: Sep 2009
Location: Charleston, WV
Posts: 238
Thanks: 12
Thanked 2 Times in 2 Posts
Navy what's it's location?
__________________
WVBird99 is offline   Reply With Quote
Old 10-30-2013, 08:55 AM   #19
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,414
Thanks: 35
Thanked 953 Times in 861 Posts
Garage
not sure on a V-6
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 191k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..
NavyVet is offline   Reply With Quote
Old 10-30-2013, 12:26 PM   #20
Token Firebird Owner
Feedback Score: 7 reviews
 
ZexGX's Avatar
 
Join Date: Apr 2009
Location: All Over Southern California
Posts: 9,413
Thanks: 1,101
Thanked 486 Times in 384 Posts
At 123k miles I'm leaning towards catalytic converter. Mine went bad at about that many miles. As mentioned above, the symptoms your car has (especially not being able to rev past 4000 RPM) are typical signs of a clogged catalytic converter.
__________________

__________________

I've got my D1SC in a box.
ZexGX is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey fellas, its electrical! WVBird99 V6 Camaro and Firebird Tech 29 10-12-2012 01:22 AM
Hey fellas WVBird99 General Discussion 0 09-20-2012 06:15 PM
Hello fellas ashman333 Introductions 9 09-06-2011 09:48 PM




Powered by vBadvanced CMPS v3.2.3

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:24 AM.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

Camaro News Delivered to your Email!

Get the latest Camaro news straight to your inbox!

unsusbcribe at anytime with one click

Close [X]