92 rs TBI shaking in gear - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 3rd Gen (1982-92) Camaro and Firebird Tech

Join Camaro Zone Today
Reply
 
LinkBack Thread Tools
 
Old 07-29-2013, 08:42 PM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: May 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
92 rs TBI shaking in gear

I had a huge issue a few weeks ago where my car would surge while idling. Replaced all the sensors, and checked for leaks found none. Turns out it was my distributor, the inside was rust and fell apart after I took it out. Anyways put new one in and idled steady just a bit rough. At high rpm would idle fine, but put in gear and shakes like i got a cam, which I don't its all stock. I figured it was the plugs and wires, no big deal. Well replaced them and still shakes. Now I put the distributor in right, set it to 0 timing with the computer wire unhooked, unhooked battery and hooked computer wire back up and it regulates the timing at around 6+ to 10+ so i read thats right. All the plug wires are right, the car has power after you get past 45, but lacks the pick up it had, and shakes like crazy. My friend suggest there could be an issue with the new distributor. Also it smells of fuel pretty bad.
__________________

__________________
darrkbeast is offline   Reply With Quote
Old 07-30-2013, 01:21 AM   #2
Member
Feedback Score: 0 reviews
 
87z28camaro's Avatar
 
Join Date: Oct 2012
Posts: 470
Thanks: 4
Thanked 0 Times in 0 Posts
Could maybe be the clutch?
__________________

__________________
87z28camaro is offline   Reply With Quote
Old 07-30-2013, 02:17 AM   #3
Veteran Member
Feedback Score: 0 reviews
 
1987 IROC Z28's Avatar
 
Join Date: Mar 2012
Location: Mukilteo, WA
Posts: 2,424
Thanks: 28
Thanked 13 Times in 13 Posts
Garage
Check your fuel lines. Also shaking could be from a misfire. Throwing any codes?
__________________
1987 IROC Z28 is offline   Reply With Quote
Old 07-30-2013, 08:20 AM   #4
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,678
Thanks: 36
Thanked 979 Times in 881 Posts
Garage
Did you gap the plugs before you put them in.
Smelling of gas means it's running rich or not burning all of the fuel.
Are you sure you got the plug wires in the distributor in the the correct firing order?
__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 192k miles and counting.
Total engine rebuild at 187,020 miles. AIR delete, bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs.
Custom leather interior at 189k miles
NavyVet is offline   Reply With Quote
Old 08-01-2013, 07:53 PM   #5
New Member
Feedback Score: 0 reviews
 
Join Date: May 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Yeah I double checked the wires and made sure the distributor was in 100% right. No codes come up. I'm going to pull the plugs this weekend again, maybe grab a new pair just to make sure. I gapped them before I put them in, but never know so Ill check them this weekend.
__________________
darrkbeast is offline   Reply With Quote
Old 08-11-2013, 12:36 PM   #6
New Member
Feedback Score: 0 reviews
 
Join Date: May 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Still idle wierd

So I pulled the plugs, all gaped right and dont look bad. Just to make sure I got new ones, regapped and put them in. Nothing changed. In park the car idles fine, smooth no shaking but when you put in gear it idles like I have a cam in it. Im going to replace the egr valve and the idle control sensor see if that helps.
__________________
darrkbeast is offline   Reply With Quote
Old 08-11-2013, 01:03 PM   #7
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 15,678
Thanks: 36
Thanked 979 Times in 881 Posts
Garage
Does the distributor have a vacuum advance on it?
If so, have you checked toi make sure it isn't leaking meaning the diaphragm has failed?
__________________

__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 192k miles and counting.
Total engine rebuild at 187,020 miles. AIR delete, bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs.
Custom leather interior at 189k miles
NavyVet is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Just some general info on tbi for the tbi haters or looking for tbi performance info natethegreat1991 General Discussion 7 06-05-2012 08:28 PM
Car shaking when stopping wolfeman 4th Gen (1998-02) Camaro and Firebird Tech 7 04-22-2012 06:13 PM
Shaking bigdoffmb 4th Gen (1993-97) Camaro and Firebird Tech 2 03-30-2012 09:20 AM
Shaking Headlights thermopylae_480 Appearance and Car Care 18 11-15-2009 09:48 PM
tech questions about 305 tbi to 350 tbi switch Butch 3rd Gen (1982-92) Camaro and Firebird Tech 3 04-23-2008 01:15 PM




Powered by vBadvanced CMPS v3.2.3

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 07:53 AM.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

Camaro News Delivered to your Email!

Get the latest Camaro news straight to your inbox!

unsusbcribe at anytime with one click

Close [X]