Car changes gear at high RPM. - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 3rd Gen (1982-92) Camaro and Firebird Tech

Join Camaro Zone Today
Reply
 
LinkBack Thread Tools
 
Old 06-22-2013, 03:23 AM   #1
Junior Member
Feedback Score: 0 reviews
 
91V8Project's Avatar
 
Join Date: Mar 2013
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Car changes gear at high RPM.

I have a 91 RS V8 305 TBI Automatic.

When I floor it, it takes a while to go up to speed, it does it in all gears. It changes gear around 8500 RPM (yeah I know, it doesn't show that in the RPM gauges but it takes a while like it wants to keep going.
I believe it is the torque converter because that's the only thing that is working in every gear except park and neutral. It could be the servos that are getting stuck. I haven't done a transmission fluid change on it. So I don't know if there are any metal shavings to indicate me of a bad internal problem.
Anyone have any idea?
__________________

__________________
91V8Project is offline   Reply With Quote
Old 06-22-2013, 09:49 AM   #2
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 14,370
Thanks: 32
Thanked 831 Times in 759 Posts
Garage
It's possible that the TV cable ( kick down cable ) is out of adjustment.
__________________

__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 188k miles and counting.
Total engine rebuild at 187,020 miles.
AIR delete. Bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs..
lift I .500 E .510 duration I 266 E 276
NavyVet is offline   Reply With Quote
Old 06-22-2013, 11:31 AM   #3
Veteran Member
Feedback Score: 0 reviews
 
cammy's Avatar
 
Join Date: Jan 2010
Location: Hinton, OK
Posts: 2,723
Thanks: 4
Thanked 43 Times in 36 Posts
Garage
Take the cable off the throttle. Gentley yank it back and forth like 30 times. Hook it back up and go so a easy ride. If it doesn't do anything do that a couple more times. Sounds like its stuck. Might put some trans x or another good brand in the tranny.
__________________
cammy is online now   Reply With Quote
Old 06-22-2013, 04:23 PM   #4
Junior Member
Feedback Score: 0 reviews
 
91V8Project's Avatar
 
Join Date: Mar 2013
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
That's right! The TV Cable. I forgot about that. Maybe that could be the problem. I'll try an adjust it tomorrow morning. I'll try also pulling it because maybe it is also getting stuck.
__________________
91V8Project is offline   Reply With Quote
Old 06-22-2013, 04:40 PM   #5
Veteran Member
Feedback Score: 0 reviews
 
cammy's Avatar
 
Join Date: Jan 2010
Location: Hinton, OK
Posts: 2,723
Thanks: 4
Thanked 43 Times in 36 Posts
Garage
When u go to adjust it. Losen it like it was a new cable. Get in side and stomp the gas peddle to the floor. Poof your adjusted. Also check and make sure your cable hasn't stretched. That can cause problems as well. Not common but can happen. Just have a buddy pish the pedal to the floor. You look at the butterfly and see if its all the way open.
__________________
cammy is online now   Reply With Quote
Old 06-24-2013, 02:53 PM   #6
Member
Feedback Score: 0 reviews
 
JNICK9900's Avatar
 
Join Date: Jun 2012
Posts: 105
Thanks: 1
Thanked 2 Times in 2 Posts
Had a loose vac line running to my trans that had a hole in and caused a similar issue
__________________

__________________
JNICK9900 is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
car stutters on high rpm Hxrodri1 V6 Camaro and Firebird Tech 11 07-21-2012 01:13 AM
High idle rpm's Longwell General Camaro & Firebird Tech 35 09-01-2011 12:11 PM
Car will not shift into third gear? deftones44330 4th Gen (1993-97) Camaro and Firebird Tech 4 08-18-2010 06:24 PM
Car Missing When accelerating during low RPM BS93Z28 4th Gen (1993-97) Camaro and Firebird Tech 3 04-30-2010 09:41 PM
Need a chop of my car in high res.----> JPack Photoshop and Editing 9 04-20-2007 11:17 PM




Powered by vBadvanced CMPS v3.2.3

Our Communities

Our communities encompass many different hobbies and interests, but each one is built on friendly, intelligent membership.

» More about our Communities

Automotive Communities

Our Automotive communities encompass many different makes and models. From U.S. domestics to European Saloons.

» More about our Automotive Communities

RV & Travel Trailer Communities

Our RV & Travel Trailer sites encompasses virtually all types of Recreational Vehicles, from brand-specific to general RV communities.

» More about our RV Communities

Marine Communities

Our Marine websites focus on Cruising and Sailing Vessels, including forums and the largest cruising Wiki project on the web today.

» More about our Marine Communities


Copyright 2002-2012 Social Knowledge, LLC All Rights Reserved.

All times are GMT -4. The time now is 03:01 AM.
Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
Copyright © CamaroZone.com

Camaro News Delivered to your Email!

Get the latest Camaro news straight to your inbox!

unsusbcribe at anytime with one click

Close [X]