My '67 Camaro "rebirth" blog is starting - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > General Discussion Forums > Members Camaros and Firebirds

Reply
 
LinkBack Thread Tools
 
Old 04-16-2017, 08:04 PM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: Mar 2017
Location: San Mateo CA
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
My '67 Camaro "rebirth" blog is starting

Hi to anyone who cares, LOL.
I just joined a few weeks ago but I have had my 1967 Factory RS/SS Camaro since about 1977. I bought it from the third owner as a "stolen recovery" without an engine. trans, hood and a bunch of other missing parts and spent the next three years gathering parts while I worked on other car and motorcycle projects. I put it into "temporary" storage in 1983 (yes, 1983) and well, life happened and taking it out kept getting put off.
Fast forward 33 years and it's now out of storage and "home again".
I just started the blog (my first so pretty bare and non professional but it will get added to and get better as I go along.
If you care to find it its at http://.www.jimrs67camaroproject.org
I seem to be able to get to it from the Google search bar at jimrs67camaroproject.org
I'll try to stay on top of and post what I'm doing on a fairly regular basis and comments are welcome
Thanks, Jim R.
Jim Rankin is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 05-02-2017, 12:55 PM   #2
New Member
Feedback Score: 0 reviews
 
Join Date: May 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
hi Jim i too have a 67 rs ss thats been in storage since 1974 , had a new crate engine installed ran great then . pulled out of storage , have replaced carb , distributor , fuel pump, fuel line , spark plugs ,wires,cap, had tank cleaned ,new flame thrower ign and coil ,.will not run pour gas in carb pops and sputters .any suggestions what might cause this problems at wits end.
lawrence romanowski is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
AMT Racing's 1981 Chevy Camaro, The "Quiet Riot". AMT4180 Members Camaros and Firebirds 43 08-28-2015 01:29 PM
'89 Camaro VATS Ign lock Stuck in "Run" position???? torquedork 3rd Gen (1982-92) Camaro and Firebird Tech 7 05-03-2013 05:12 PM
oil pressure pegged out after starting.. "whirring noise" shaunmccreary 4th Gen (1998-02) Camaro and Firebird Tech 10 10-16-2010 09:46 AM
Transmission shifts "quick" and has a "jerk" to it. cmw0021 V6 Camaro and Firebird Tech 6 01-15-2010 09:09 PM
GM Issues First "Official" Shot of Production 2009 Chevrolet Camaro FBO News Bot Camaro & Firebird News 0 10-17-2007 03:41 PM


Powered by vBadvanced CMPS v3.2.3


All times are GMT -4. The time now is 04:38 PM.
Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.