93 z28 oil pressure low - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 4th Gen (1993-97) Camaro and Firebird Tech

Reply
 
LinkBack Thread Tools
 
Old 06-27-2018, 11:34 AM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: Feb 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
93 z28 oil pressure low

I have a 93 z28 when i start it up the oil presure is high but after i drive it n it warms up it starts to drop
joshuagiles2009 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-27-2018, 11:55 AM   #2
CZ Vendor
Feedback Score: 1 reviews
 
Ercmann's Avatar
 
Join Date: Nov 2011
Location: Okaloosa, Florida
Posts: 11,462
Thanks: 48
Thanked 675 Times in 617 Posts
Garage
Quote:
Originally Posted by joshuagiles2009 View Post
I have a 93 z28 when i start it up the oil presure is high but after i drive it n it warms up it starts to drop
Starts to drop to what?
__________________

2001 Camaro SS LS1, M6
SLP Build #1040
"Concert Hall On Wheels"
"It's better to have it and not need it, than to need it and not have it"
http://www.ercsaudio.com/
10% OFF LIFETIME Site-Wide Discount Code at ErcsAudio, for ALL CZ Members!! Enter Code CZ10LIFE at checkout!
https://www.camarozone.com/forum/f18/erics-01-ss-
mod-thread-178452/
https://www.camarozone.com/forum/f27/...m-poll-180546/
Ercmann is offline   Reply With Quote
The Following User Says Thank You to Ercmann For This Useful Post:
Old 06-27-2018, 02:21 PM   #3
Junior Member
Feedback Score: 0 reviews
 
BigBowtie85's Avatar
 
Join Date: Oct 2016
Posts: 71
Thanks: 0
Thanked 4 Times in 4 Posts
If its anywhere near 10-20 psi warm, it's normal. People always freak out about the oil pressure once they get a car that actually has a gauge for it. 40-60 cold is pretty normal at startup, 10-20 when its warm is too.

Oil pressure will drop when the oil warms up because its resistance to flow (aka viscosity) changes. No need to worry unless the gauge is showing radical numbers (usually a sensor issue) or your oil level is incredibly to the point that even at cold temps its a low PSI.
BigBowtie85 is offline   Reply With Quote
The Following User Says Thank You to BigBowtie85 For This Useful Post:
Sponsored Links
Advertisement
 
Old 06-29-2018, 07:12 PM   #4
New Member
Feedback Score: 0 reviews
 
Marrct44's Avatar
 
Join Date: Feb 2018
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Normal oil pressure is 10-20? I have a 2000 3.8L and my oil pressure upon startup and constant while driving is 65. Is this normal? It never goes up or down, car does not leak a drop of oil whatsoever and when I go to change oil it’s clean as a whistle
Attached Thumbnails
Click image for larger version

Name:	A34818C0-A9CF-4AC4-8568-64B09997405F_1530313951592.jpg
Views:	25
Size:	52.8 KB
ID:	38973  
Marrct44 is offline   Reply With Quote
Old 06-29-2018, 08:20 PM   #5
Senior Member
Feedback Score: 0 reviews
 
Join Date: Jul 2014
Location: Westchester, Plattsburgh, NY
Posts: 610
Thanks: 27
Thanked 11 Times in 11 Posts
Garage
My 3.8 Camaro showed very low oil pressure until I replaced the sensor. After that, the pressure appeared to always be inordinately high (120 when cold starting and accelerating). My 3.4 Camaro showed zero pressure on the gauge and yet the motor was still kicking.
If there's actually a problem, trust me, you'll know.
SergheiS is offline   Reply With Quote
Old 07-06-2018, 02:28 PM   #6
New Member
Feedback Score: 0 reviews
 
Join Date: Feb 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Ercmann View Post
Starts to drop to what?
All the way down then shuts off
joshuagiles2009 is offline   Reply With Quote
Old 08-14-2018, 08:35 PM   #7
New Member
Feedback Score: 0 reviews
 
Join Date: Feb 2016
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Oil pressure

Quote:
Originally Posted by Ercmann View Post
Starts to drop to what?

10 n under overheats and then shuts off
joshuagiles2009 is offline   Reply With Quote
Old 08-15-2018, 08:51 AM   #8
New Member
Feedback Score: 0 reviews
 
Join Date: Aug 2018
Location: S.Central Lousiana
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
Garage
Thanks for posting this Trend / Question. I am a new owner of a 97 Z and was a little bothered by seeing my pressure drop at idle to about 20psi then rise back to the normal range after moving back up to speed again. This info was very helpful Thanks.

Question: I recently owned a 2004 SSR and there were issues with the "Stepper Motors" on ALL the gauges. Does the 4th Gen. Camaro have "Mechanical" gauges / instruments or the "Stepper Motors"
97Z28POLOGREEN is offline   Reply With Quote
Old 08-16-2018, 02:01 PM   #9
Addicted Member
Feedback Score: 4 reviews
 
96firephoenix's Avatar
 
Join Date: Jun 2009
Location: Indianapolis, IN
Posts: 6,674
Thanks: 58
Thanked 131 Times in 119 Posts
Send a message via AIM to 96firephoenix
4th gen has the stepper motor type gauges, not the mechanical gauges.

I think 93/94 might have had a speedo cable, but I"m not sure.
__________________

A.J.
1996 Firebird 3800 Series II, T5 swap RIP 3-31-11
It lives on: Engine and trans from ^ are now in v
1996 Firebird 3800 Series II, T5
96firephoenix is offline   Reply With Quote
Old 08-17-2018, 06:56 PM   #10
New Member
Feedback Score: 0 reviews
 
Join Date: May 2009
Location: Lawrenceville, GA
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Talking

Quote:
Originally Posted by BigBowtie85 View Post
If its anywhere near 10-20 psi warm, it's normal. People always freak out about the oil pressure once they get a car that actually has a gauge for it. 40-60 cold is pretty normal at startup, 10-20 when its warm is too.

Oil pressure will drop when the oil warms up because its resistance to flow (aka viscosity) changes. No need to worry unless the gauge is showing radical numbers (usually a sensor issue) or your oil level is incredibly to the point that even at cold temps its a low PSI.
Ditto on the above.

Bill
__________________
2001 Camaro SS LPM A4

Ported Dart 205's-TSP Cam 233/233 .595 .595 112 +2-#42 injectors-LS6 Ported Oil Pump-Dual Rollmaster Chain-SLP Headers-TCI SSF3500-Walbro Fuel Pump-HSW Wet N20 Plate-Koni's
BowlingSS is offline   Reply With Quote
Old 02-12-2019, 10:56 PM   #11
New Member
Feedback Score: 0 reviews
 
steve97camaro's Avatar
 
Join Date: Jun 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
I’ve noticed after installing fan switches to keep coolant and trans fluid cooler that the oil is a bit cooler and keeping my psi a little higher while running in my 93 t/a
steve97camaro is offline   Reply With Quote
Old 02-16-2019, 04:56 PM   #12
CZ Vendor
Feedback Score: 1 reviews
 
Ercmann's Avatar
 
Join Date: Nov 2011
Location: Okaloosa, Florida
Posts: 11,462
Thanks: 48
Thanked 675 Times in 617 Posts
Garage
Quote:
Originally Posted by steve97camaro View Post
I’ve noticed after installing fan switches to keep coolant and trans fluid cooler that the oil is a bit cooler and keeping my psi a little higher while running in my 93 t/a
That's because cooler oil is thicker resulting in a higher pressure reading. I am sure you notice the oil pressure is higher when the engine temp is cooler, like at first start-up? Then lowers as the engine gets hotter.
__________________

2001 Camaro SS LS1, M6
SLP Build #1040
"Concert Hall On Wheels"
"It's better to have it and not need it, than to need it and not have it"
http://www.ercsaudio.com/
10% OFF LIFETIME Site-Wide Discount Code at ErcsAudio, for ALL CZ Members!! Enter Code CZ10LIFE at checkout!
https://www.camarozone.com/forum/f18/erics-01-ss-
mod-thread-178452/
https://www.camarozone.com/forum/f27/...m-poll-180546/
Ercmann is offline   Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Low Oil Pressure/Oil leak LS1GOAT V6 Camaro and Firebird Tech 23 01-30-2012 01:47 PM
puzzled again low oil pressure 94RS V6 Camaro and Firebird Tech 11 09-20-2011 01:47 PM
96 TA low oil pressure showing on gauge eclipse 4th Gen (1993-97) Camaro and Firebird Tech 11 05-02-2011 03:44 AM
Low Revs/Oil Pressure/Starting trouble Zimbabwe 4th Gen (1998-02) Camaro and Firebird Tech 1 09-15-2009 12:24 AM
97 Firebird low oil pressure HotBlue02 4th Gen (1993-97) Camaro and Firebird Tech 3 12-27-2008 12:04 AM


Powered by vBadvanced CMPS v3.2.3


All times are GMT -4. The time now is 08:52 PM.
Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.