94 z28 LT1 ignition problem??? - Page 2 - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 4th Gen (1993-97) Camaro and Firebird Tech

Reply
 
LinkBack Thread Tools
 
Old 09-28-2014, 02:44 AM   #21
New Member
Feedback Score: 0 reviews
 
Join Date: Sep 2014
Posts: 17
Thanks: 0
Thanked 0 Times in 0 Posts
Hey guys new to the site, I have a 95 z28 with code 43 I also had a code for the knock sensor which I already fixed but the code 43 for the ignition control grounded circuit keeps coming up where should I start with this code? Any help would be greatly appreciated
Thanks,
Craig


Sent from my iPhone using Camaro Zone
1fastz2834 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-29-2014, 12:15 PM   #22
Junior Member
Feedback Score: 0 reviews
 
Join Date: Dec 2013
Location: Long Island, New York
Posts: 30
Thanks: 1
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by NavyVet View Post
Why don't you just replace the switch?
I've replaced everything down to the opti as well, still no win
2cars2camaros is offline   Reply With Quote
Old 09-29-2014, 06:38 PM   #23
The "Senior" Member
Feedback Score: 1 reviews
 
NavyVet's Avatar
 
Join Date: Jan 2010
Location: Jacksonville, FL
Posts: 18,265
Thanks: 49
Thanked 1,219 Times in 1,092 Posts
Garage
Quote:
Originally Posted by 2cars2camaros View Post
I've replaced everything down to the opti as well, still no win
You have to squeeze and twist the electrical ignition switch to start the engine, correct?
Why not replace the switch.

__________________

96 T/A, Black/Graphite Leather, T-Tops, 6 speed, 10 speaker Delco/Bose "Monsoon"
Original owner, 217k miles and counting.
Total engine rebuild at 187,020 miles. AIR delete, bored .030 over.
Comp cams Xtreme Energy LT1 266HR-14 street cam and springs.
Custom leather interior at 190k miles. Total repaint 193k Miles
26PPH injectors.
NavyVet is offline   Reply With Quote
Reply

Tags
icm, ignition, problem, tps, z28

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can some one help me how to fix my ignition problem rafaelbazan Introductions 11 08-24-2012 09:15 AM
ignition problem Iroca86z28 3rd Gen (1982-92) Camaro and Firebird Tech 5 03-27-2012 03:23 AM
Lt1 ignition problem diablosmaro 4th Gen (1993-97) Camaro and Firebird Tech 19 01-25-2012 03:05 AM
Starter or Ignition Problem shmoogie General Camaro & Firebird Tech 12 04-25-2011 12:27 AM
Ignition problem Battousai V6 Camaro and Firebird Tech 4 06-11-2010 01:11 PM


Powered by vBadvanced CMPS v3.2.3


All times are GMT -4. The time now is 05:38 AM.
Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.