Wiper - Camaro Zone - Camaro Forums and News

Go Back   Camaro Zone - Camaro Forums and News > Camaro & Firebird Tech Forums > 1st Gen & 2nd Gen (1967-81) Tech

Reply
 
LinkBack Thread Tools
 
Old 08-23-2019, 07:08 PM   #1
New Member
Feedback Score: 0 reviews
 
Join Date: May 2015
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Wiper

So, I just get my Camaro back from shop after 2 months of rocker panel reconstruction. I go to get sticker, and fail, due to wipers not working.
When I turn on wipers, they move an inch and blow a fuse.
I have checked all the wiring and even a stronger amp fuse and they all blow.
I also , disconnected the wiring on wiper motor, put new fuse in and turned on wipers, and the fuse did not blow. Would that eliminate the dash switch from the problem?
Any suggestions
Thanks
Barry
Barry J is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off



Powered by vBadvanced CMPS v3.2.3


All times are GMT -4. The time now is 02:46 AM.
Powered by vBulletin®
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.