Camaro Zone - Camaro Forums and News - View Profile: Firebird T/A

Go Back   Camaro Zone - Camaro Forums and News > Members List

Firebird T/A Firebird T/A is offline

New Member

Visitor Messages

Showing Visitor Messages 1 to 2 of 2
  1. marks146
    10-28-2012 09:02 PM - permalink
    marks146
    Turned out it was the spark plugs. I took out the brand new Bosch +4 that I thought would work, and put in AC "Pro" and the miss is gone. Put in the exact plugs the factory installed when the car is new. That did the trick.
  2. Rocket 442
    10-05-2012 07:09 AM - permalink
    Rocket 442
    Welcome to Camaro Zone. Thanks for registering.

    You can edit your profile or Upload pics of your Camaro or Firebird to your own personal albums, and of course, don't forget to Introduce Yourself to the rest of Camaro Zone.
    Thanks for Registering, and don't be afraid to ask questions or make suggestions!

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Last Activity: 12-08-2012 04:43 AM
  • Join Date: 10-05-2012
  • Referrals: 0

Garage

    1996 pontiac trans am
    Firebird trans am

Feedback Score

Member Profile Recent Ratings
Feedback Score:
Positive Feedback:
0
0%
Members who left positive:
Members who left negative:
0
0
Total positive feedback: 0
View full profile for Firebird T/A
  Past
Month
Past
6 Months
Past
12 Months
 Positive 0 0 0
 Neutral 0 0 0
 Negative 0 0 0


All times are GMT -4. The time now is 09:04 AM.
Powered by vBulletin®
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
SEO by vBSEO 3.6.0
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright © CamaroZone.com

CamaroZone.com is in no way associated with or endorsed by General Motors or Chevrolet.