Camaro Zone Forums banner
fan
1-5 of 5 Results
  1. V6 Camaro and Firebird Tech
    So I have a 3800 v6 manual and my temp gauge is reading zero and my service engine soon light is on and also when i start up the fan comes on high. Just wondering what might be the problem, if it is the coolant temp sensor or something with the thermostat.
  2. 4th Gen (1993-97) Camaro and Firebird Tech
    I was wondering if anyone has made a sticky about changing the fans to allow them to run whenever you switch them on and off rather than rely on the temp sensor? I did a search and didn't find anything!? Some links would be nice. Thanks in advance guys!
  3. 4th Gen (1993-97) Camaro and Firebird Tech
    My question is when I start the car even when it is completely cold out the fans kick in after a minute or 2. The temp sensor is freshly replaced as of last year and the car reads cold still on the temp gauge. Car is 5.7 with around 86000 miles on it. I was just curious is this okay or is...
    fan
  4. 4th Gen (1998-02) Camaro and Firebird Tech
    Hello everyone, My 98 v6 Camaro's defrost and heater stopped blowing recently. The fan and belts are fine, my battery and alternator are brand new, and no fuses are blown. Could it be the blower motor? Before the vents stopped blowing altogether, the a/c would blow, but not cool. I found...
  5. V6 Camaro and Firebird Tech
    hello, I am new here but yal all seemed like the guys I needed to ask for this :) I have recently restored a 1951 Willys Wagon but i got the exact motor out of a stock '95 V6 3.4L Camaro. I got the 3in thick manual for it and traced each and every wire being sure not to cut any i do not need...
1-5 of 5 Results
Top