Camaro Zone Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 · (Edited)
When i was driving about 90mph, the serpentine belt was went.Why? After that i drove 3-5 miles to home where i saw it. I bought and replaced a new one. Also i heard some bad metallic sound on the front of the engine. My friend told me water pump need to replace. I did it. Today i saw leak from the radiator... I can replace it. It's easy and inexpensive. But i believe problem is not radiator. Mileage 140k. I read probably it's head gasket bad and exhaust gas put to cooling system and make too high pressure. How to know make sure? Also i replaced a new one radiator cap before.:icon_neutral:
 

·
CZ's Turbo Gawd
Joined
·
7,943 Posts
You don't really have head gasket symptoms. There's a coolant elbow that is prone to leaking on those cars. A metallic sound could have been the water pump or a bad pully.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #3 ·
well, if i'll buy a new radiator - what should i do? How to exclude this problem again? How to remove possible air from the cooling system?
 

·
Registered
Joined
·
28 Posts
Head gasket symptom

My head gasket was leaking pushing air into the system, pressurizing it, and it would force out of the reservoir. So unless that's happening shouldn't be head gasket causing the leak
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #5 ·
do u mean it was wrong radiator cap? But i replaced it.
Always i saw some leak from the upper radiator hose.
But only after i was lost serpentine belt(i don't know why it's happened) - radiator was damaged.
Any suggestion?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #8 ·
why both?
I replaced a new radiator and i have no leak anywhere. I used only one bleeder - anybody knows where located another bleeder on 3800 V6 Camaro 1998?
P.S.: On my old radiator was tiny crack near upper hose connector. I believe it was when i bought this car. Does it mean the coolant system always had air pockets?
 

·
CZ's Turbo Gawd
Joined
·
7,943 Posts
If one head gasket failed the other side isn't far behind. Replacing head gaskets is a somewhat long job, if your taking the time to pull the top end off the motor it only makes sense to replace both while you're in there.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #10 ·
i believe the gaskets are OK.
Probably just need remove some air pockets after radiator replacing and coolant added?
One bleeder located near Thermostat - where's another?
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #11 · (Edited)
Today my upper radiator hose has broken ...
i think it's a head gasket...
But i have read about air pockets... i don't know what to do...
I had bought(PepBoys) a new upper hose and replaced it - but it has little wrong curve.
I think Thermostat is located under engine tube(fitting) where connected upper radiator hose - correct? Also i have read that Camaro V6 engine has not standard coolant circuit - right? Where may i see how works thermostat on this engine?
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top